The Way towards Amplifier Design Using CAD (ADS) Tool


*Department of electrical, electronic, control and instrumental engineering, Hanyang University, ERICA campus, South Korea
**Department of computer engineering, Hanyang University, ERICA campus, South Korea
{ Zeeshankaleem, saqib.uet1, mohsin.professional, engr.farrukhsaleem} @gmail.com, cklee@hanyang.ac.kr

Abstract—This paper mainly focuses on design arts and operational mechanism of ADS tool. ADS tool is characterized by reliable, efficient and controlled functioning as compare to conventional approaches. In this paper, we describe an ADS tool based interactive procedure that provides the students in electrical and computer engineering programs with an easy-to-use reference and overview of an amplifier design. This multimedia-based system covers topics that start with introductory basic concepts in amplifier design and conclude with advanced and detailed concepts using the ADS tool.

Keywords— Amplifier, ADS tool, stability, gain, smith chart

I. INTRODUCTION

The Advancements in the electronics and computer industries, emerging newer technologies and the designer needs their product in a market fast and first and at a reduce cost [1]. This has significantly increased the scope of background, knowledge and technical skills required by the personal concerned with such type of issues. The step towards using a CAD tools is that since the mathematics of active circuit design are too complex for manual computations. The tutorial designed is targeted towards first-time users of ADS tool for designing an amplifier.

The popularity of ADS tool has also resulted in a number of tutorial [2], [3]. Since there are many tutorial available but presently there are no such complete tutorial which can explain learner the basics of amplifier and their CAD design steps in one tutorial. They are basically computer based textbooks, and lack significant student interaction or feedback. This paper describes a unique, interactive, computer based named, the way towards amplifier design using CAD (ADS) tool, for independent learning of amplifier design.

The amplifier is an integral part of any communication system. The purpose of having an amplifier in a system is to boost the signal to the desired level. It also helps to keep the signal well above noise so that it can be analyzed easily and accurately. Though many CAD tools are available which had made the designing and analyzing the system quite easy, Advanced Design System (ADS) is the world’s leading electronic design automation (EDA) software for RF, microwave, and high-speed digital design and verification. Leading companies in the wireless communication, wireless networking, signal integrity and aerospace & defense industries rely upon ADS as their high-frequency design platform for WiMAX, LTE, radar and satellite communication systems. Agilent's Advanced Design System (ADS) offers a complete range of software design tools for microwave and RF communications system, product, and component design.

Agilent ADS allows microwave engineers to analyze, design, and simulate active and passive microwave components and systems. Layout and powerful optimizers in ADS help increase productivity and efficiency, validating high-yield designs prior to manufacturing.

Agilent offers design, simulation and test capability for all of your RF and microwave amplifier design and test needs. Designers of low-noise amplifiers and power amplifiers can use harmonic balance simulation in Advanced Design System (ADS) to characterize gain compression and noise.

After designing your amplifier and building a prototype, you can utilize Agilent test equipment to verify your designs. Agilent products include Network Analyzers, Spectrum Analyzers, Signal Sources, Oscilloscopes and more, all for your amplifier test requirements [4].

The intent was to develop a practical guide for independent study by learners who had little or no exposure to amplifier design by using ADS tool. Some of the goals of this paper were to:
1. Engage students as active learners in exploring new concepts immediately with interactive exercises;
2. Allow students to proceed at their own pace and plan;
3. Permit the learning to take place off-campus.

This paper has been divided into four sections, first describes the introduction, second part describes the amplifier design mechanism, third part describes the details of the amplifier design mechanism, including gain; stability conditions etc. and then final part describes the amplifier design in ADS tool.

II. AMPLIFIER DESIGN MECHANISM

There are many references available on basic amplifier concept and design. The procedure
presented in this paper is an easiest way for learning an amplifier design. Firstly we describe ideal procedural steps for designing an amplifier.

1) Check stability performance by calculating Rolette stability factor $K$, using the S-parameters of the transistor at a given frequency and plot respective stability circles to determine unstable region in the smith chart for $\Gamma_l$ and $\Gamma_L$.

2) If the transistor is potentially unstable then we have to add some resistor but this will increase the noise figure.

3) Calculate unilateral figure of merit to determine whether to use Unilateral or bilateral design.

4) Calculate $\text{NF}_{\text{min}}$ and $\Gamma_{\text{OPT}}$ of the transistor from the S-parameter. Plot the noise circle by choosing appropriate $\text{NF}_{\text{min}}$ value

5) For unilateral case use the constant gain circles for the desired or maximum gain and for bilateral case use the available power gain circles for the desired or maximum gain.

6) Choose a $\Gamma_{\text{L}}$ value in the stable region and as well as within the noise circle and corresponding gain circle. We are not using operating power gain circle as it is to be plotted in $\Gamma_{\text{OUT}}$ So difficult to correlate with the noise circles in the $\Gamma_{\text{IN}}$ plane.

7) Calculate the corresponding $\Gamma_{\text{L}}$. From the corresponding $\Gamma$ calculate the $Z_{\text{in}}$ and $Z_{\text{L}}$.

8) These are the impedance values for a given noise figure, gain etc for the transistor. Now these have to be matched with their corresponding source and load impedance $Z_{\text{in}}$.

9) The impedance matching networks are designed using smith chart.

III. AMPLIFIER CHARACTERISTICS

A. Gain Performance

There is several power gain equations used in design of amplifier. The transducer power gain $G_T$, the operating power gain $G_P$, and the available power gain $G_A$ defined as follows.

$$G_T = \frac{\text{power delivered to the load}}{\text{power available from the source}}$$

$$G_P = \frac{\text{power delivered to the load}}{\text{power input to the network}}$$

$$G_A = \frac{\text{power available from the network}}{\text{power available from the source}}$$

The maximum available gain (sometimes called MAG, sometimes called GMAX) of a device is only defined where K is greater than one. This is because the term under the square-root becomes negative for values of K less than 1. And then gain is infinite. Infinite gain means oscillator.

The maximum stable gain (MSG) of a device is defined when maximum available gain is undefined (K<1). It is merely the ratio of $\text{mag}(S_{12})/\text{mag}(S_{12})$.

The maximum gain available (MAG) and can be calculated by using $S$-Parameter and $k$ as expressed in (1).

$$MAG = \frac{S_{12}}{S_{21}} \left( k \pm \sqrt{k^2 - 1} \right)$$

1) Available Gain & Power Gain Circles ($G_A,G_P$)

An available gain input network circle is a locus of source impedances for a given gain below the optimum gain. The center of the circle is the point of maximum gain. Similarly, the power gain output network circle is a locus of load impedances for a given gain below the optimum gain. If the stability factor K is less than unity, then the 0 dB circle is at GMAX, and the inside of this circle is shaded as an unstable region.

2) $G_A$ versus noise tradeoff

When gain is not sufficient quantity to explain, then we can plot constant available gain and constant-noise circles to investigate possible trade-offs between gain and noise. So we have to take the point where we can compromise between the noise and Gain.

3) $G_P$ versus $P_{\text{OUT}}$ trade-offs

Just as we face trade-offs between noise performance and gain at the input of low-noise circuits, similar trade-offs between the small-signal gain and maximum output power exist at the output of an active two-port. When the constant-output-power contours and operating constant-gain circles are superimposed on the Smith chart, we can choose the load either for maximum gain or maximum output power, or for a compromise between these two extremes.

B. Stability Conditions

Stability, in referring to amplifiers, refers to an amplifier’s immunity to causing spurious oscillations. There are two traditional expressions used when speaking of stability: conditional and unconditional stability. A network is conditionally stable if the real part of $Z_{\text{in}}$ and $Z_{\text{out}}$ is greater than zero for some positive real source and load impedances at a specific frequency [5].

A network is unconditionally stable if the real part of $Z_{\text{in}}$ and $Z_{\text{out}}$ is greater than zero for all positive real source and load impedances at a specific frequency. The stability of an amplifier is a very important consideration in a design and can be determined from the $S$ parameter, the matching networks, and the terminations. To stabilize the two-port, we need to know what type of terminations can lead to possible oscillation. There are three kinds of terminations that is unfriendly source terminations, Friendly terminations and borderline terminations.

When two-port is potentially unstable, then there are unfriendly source terminations for which $|F_{\text{OUT}}| > 1.0$, Friendly source terminations, when $|F_{\text{OUT}}| < 1.0$ and for Borderline terminations $|F_{\text{OUT}}| = 1.0$. The same three possibilities apply for the load terminations also. Virtually all commercially available RF/MW transistors exhibit potential instability at some frequencies. In order
to stabilize a device, we first need to identify the unfriendly terminations that may lead to oscillation, and then stabilize the device by adding a protective circuitry, so that it cannot directly interface any unfriendly termination [5].

1) Rollett's stability factor
This factor is used to tell us whether the device is stable or not. There are two possibilities either Rollett's Stability Factor, $k > 1$ or $k < 1$. When $k > 1$, the device is unconditionally stable and when $k < 1$, the device is conditionally stable and potentially unstable.

We can say that the network will be stable if the Stability or Rollett factor, $k$, is greater than one, a) $k > 1$ and b) $|\Delta| < 1$.

The stability factor is given by (2).

$$k = \frac{1 - |S_{11}|^2 - |S_{22}|^2 + |\Delta|^2}{2|S_{12}||S_{21}|} \quad |\Delta| = |S_{11}S_{22} - S_{12}S_{21}| < 1 \quad (2)$$

Unconditional stability of the circuit is the goal of the amplifier designer.

2) Stability circles
Since a picture is worth a thousand words, we again turn to a Smith chart–based graphical technique for help. A visual illustration of RF stability is done through the stability circles, where the circumference of the circles represents the locus of all borderline terminations. Accordingly, a stability circle is the border between all stable and unstable terminations. At each frequency we can find two stability circles, one for the source terminations and another for the loads.

The input and output reflection coefficients equations are given as in (3).

$$\Gamma_{in} = \frac{b_1}{a_1} = S_{11} + \frac{S_{21}S_{12}\Gamma_L}{1 - S_{22}\Gamma_L}$$

$$\Gamma_{out} = \frac{b_2}{a_2} = S_{22} + \frac{S_{21}S_{12}\Gamma_L}{1 - S_{22}\Gamma_L} \quad (3)$$

When we set $|\Gamma_{in}|$ in the equation (3) equal to one, a boundary would be established. On one side of the boundary, there would be $|\Gamma_{in}| < 1$ and on the other side there would be $|\Gamma_{in}| > 1$.

The boundary will be obtained by solving the expression as in (4)

$$|\Gamma_{in}| = |S_{11} + \frac{S_{21}S_{12}\Gamma_L}{1 - S_{22}\Gamma_L}| = 1 \quad (4)$$

The radius and centre of the circle will be given by (5) as a function of S-parameters.

$$\text{radius} = r_L = \frac{|S_{12}S_{21}|}{|S_{22}|2 - |\Delta|^2}$$

$$\text{centre} = C_L = \frac{(S_{22} - \Delta S_{11}^*)}{|S_{22}|^2 - |\Delta|^2} \quad (5)$$

By plotting these values on a Smith Chart [6], we can determine the locus of all values of $\Gamma_i$ that make $|\Gamma_{in}| = 1$. This circle then represents the boundary (Fig. 1). The area either inside or outside the circle will represent a stable operating condition.

![Figure 1. Stability circles](image)

3) Stable side
To determine which area represents this stable operating condition, let $Z_L = 50$ ohms, or $\Gamma_L = 0$. This represents the point at the center of the Smith Chart. Under these conditions, $|\Gamma_{in}| = |S_{11}|$. If $S_{11}$ is less than one than $\Gamma_{in}$ will also be less than one. This means that at this point, $\Gamma_L = 0$, represents a stable operating condition. This region (Fig. 4) then represents the stable operating condition for the entire network.

![Figure 2. Stable side determination](image)

If we select another value of $\Gamma_L$ that falls inside the stability circle, we would have an input reflection coefficient that would be greater than one, and the network would be potentially unstable.

If we only deal with passive loads, that is, loads having a reflection coefficient less than or equal to one, then we only have to stay away from those $\Gamma_L$'s that are in this region (Figure. 3) to ensure stable operation for the amplifier we are designing.
If, on the other hand, $|S_{11}| > 1$, with $Z_L = 50 \ \Omega$, then this area would be the stable region and this region the unstable area. (Fig. 4)

To ensure that we have an unconditionally stable condition at a given frequency in our amplifier design, we must be able to place any passive load on the network and drive it with any source impedance without moving into an unstable condition.

From a graphical point of view, we want to be sure that the stability circle falls completely outside the Smith Chart, and we want to make sure that the inside of the stability circle represents the unstable region (Figure 5). The area outside the stability circle, including the Smith Chart, would then represent the stable operating region [6].

IV. AMPLIFIER DESIGN USING ADS TOOL

A. Creating new project

The overview of designing any type of amplifier in ADS tool has been presented in this tutorial. Firstly open ADS program. Choose “File → New Project” to open a new project.

In the new schematic of the project, push the “Library” button to open a library lists to choose the suitable transistor model to build the amplifier. After opened the Library List window, choose “RF Transistor Library → Packaged BJTs” to choose the transistor and then you have to design suitable biasing circuit for that purpose do the DC simulation to find out the right bias points for the amplifier. After designing the suitable biasing circuit of the chosen transistor, next step in designing the amplifier with the S parameter method is to determine whether the amplifier is unconditionally stable or potentially unstable, $S_{11}$ position and gain circles for the bare transistor.

The stability factors are easily calculated using Measurement Equations in the ADS schematic panel. K is pre-programmed in as stab_fact which can be selected from the S-parameter palette on the left. Delta can be programmed yourself using a blank MeasEqn. The maximum available gain (MAG) and maximum stable gain (MSG) can also be calculated using the max_gain function.

For the S-parameter, simulation, another suitable model is needed to select from the Library List. While the “GaCircle” and “L_StabCircle” simulators can be obtained from the “Simulation-S_Param” tag.
Figure 8. Stability circle plot

After designing an appropriate circuit in ADS schematic window for checking the type of stability. The results after simulation (Fig. 8) for plotting stability circles shows that the device is conditionally stable as the stability circles clip the edge of the smith chart so that there is a possibility of instability, if a match is placed on the device source with an impedance within the area of the smith chart covered by the stability circle (as shown by the shaded area).

B. Gain and noise circles

The circles are plotted here as discussed above to find the point of compensation between these two. Now to perform gain and noise circle simulation we need to add the gain mismatch and noise mismatch simulator boxes, the noise feature has been switched on in the S-parameter simulator box. The conjugate match reflection coefficients can be calculated on ADS using the Sigm1 and Sigm2 measurement equation icons in the S-parameter palette.

The red circle shows the constant maximum available gain and the green circles are the constant gain circles. These circles have been plotted to achieve the desired gain and noise compensation.

C. Matching network design

Matching networks have two main purposes. The first is to deliver the maximum power transfer from a source in series with a source impedance of \( Z_S \) to a load impedance \( Z_L \).

The second is to provide a desired impedance to a circuit to achieve other desired characteristics, such as to filter, to maintain a desired filter transfer characteristics, to an LNA to provide a low noise figure, or to a transmission line to reduce reflections.

Load and source matching networks for amplifiers can be designed easily using the Smith Chart. The Smith Chart Utility provides full Smith Chart capabilities, synthesis of matching networks, enabling impedance matching, plotting of constant Gain / Q / VSWR / Noise circles. Choosing the matching network's topology mainly depends on the bandwidth of the amplifier.

1) Smith chart utility in ADS tool

In ADS the ‘Smith Chart Utility’ (Figure. 10) which can be used for quick design of matching networks. To activate it select the ‘Smith Chart - Matching Network’ palette and place the corresponding element between the input/output terminal and the input/output port of the transistor.

Now select ‘Design Guide->Amplifier->Tools->Smith Chart Utility’. Choose the ‘Smart Component’ you want to work upon (e.g. the input matching network) by the selection field at the upper right side.

Select ‘File->Import’ for data import into the Smith Chart Utility. Click ‘Import’ and the data is loaded. Now change the frequency to your design frequency by clicking on the arrows next to the frequency display. Click ‘OK’. The current S-parameters can be checked under ‘View->S-parameters’. All relevant design circles can be displayed by the Smith Chart Utility (‘Circles’ menu). Synthesized matching networks can be updated back to the schematic window.

The general results are showing a smith chart with constant gain and noise circles plotted. The brown circles show the constant noise circles with the blue dot showing the optimum noise point.
Analyze the results, if $S_{11}$ is zero at required frequency means good matching and from the Figure.11 it is cleared that the circuit is properly matched.

We can now simulate the circuit with the input matching circuit added to see if we get close to the required gain and noise figure. To do this the ideal transmission lines have been converted into real micro-strip transmission lines using ‘LineCalc’. The ADS schematic with input matching network added is shown in Figure.12, by simulating the network like that of your own interest you can find the desired results.

Still if you found from the results that the gain and noise figures don’t quite meet the requirements across your band of interest. For that purpose you have to add the load matching circuit into the main circuit.

So a complete circuit with input and output matching circuit is as in Fig.13.

For the design of impedance matching network, we can use the optimization function provided in ADS to find out the appropriate capacitor and inductor values of the matching networks.

V. CONCLUSION

In this paper, we described a computer-aided design interactive practical guide to design the personal concerned an enhanced understanding of amplifier and its design using ADS tool. This paper provides students with easy to-use reference and overview of a ADS tool in designing an amplifier. The paper covers topics that start with introductory basic concepts in amplifier design and conclude with advanced and detailed concepts in CAD based designed systems using ADS tool.

This paper shows that amplifiers are easily designed if a well defined procedure is followed. Designers can save time in fine tuning and optimizing the amplifier performance.

An important result of this work is that most personal will prefer this computer-based approach to learning (of this type of subject content) when compared to the traditional lecture/assignment approach. They will also feel that it is a more efficient way of learning.

REFERENCES

[2] Dr. B.S. Virdee, “Tutorial for Novices to Agilent’s Advanced Design System (ADS)”
[6] Agilent AN 154S-Parameter Design Application Note